Home > Make > Make *** Sharedmods Error 139

Make *** Sharedmods Error 139

I know homebrew doesn't explicitly support hackintoshes, but there are plenty of ivy bridge macs, so with my limited understanding of CPU architectures, I don't see why it wouldn't compile the Same Illegal instruction: 4? Is the equation pH+pOH=14 still valid at a different temperature? Beyond suggesting reinstalling OS X... have a peek at this web-site

I add a function call to the following > function: > > struct pidnode * > getPidNode( pid_t pid, struct pidnode *table) > { > struct pidnode * node; > struct I have no idea where to start orwhat might be going wrong with what you have given.Cheers,Richard. Note: See TracTickets for help on using tickets. I add a function call to the following function: struct pidnode * getPidNode( pid_t pid, struct pidnode *table) { struct pidnode * node; struct pidnode * pidanchor; pidanchor = &(table[pid %

DEBUG: Executing org.macports.build (python26) DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6' DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/Python-2.6.6" && /usr/bin/make -j5 all MAKE="/usr/bin/make CC=/usr/bin/gcc-4.2"' /bin/sh: line 1: 32774 Segmentation fault DYLD_FRAMEWORK_PATH=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python26/work/Python-2.6.6: CC='/usr/bin/gcc-4.2' LDSHARED='/usr/bin/gcc-4.2 more hot questions question feed lang-py about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation i use the ubuntu*>* 10.10 .* > You need to give more information. Join them; it only takes a minute: Sign up Compiling Python 3.4/5 fails with segmentation fault on RedHat 6.4 up vote 0 down vote favorite I try to compile a new

i use the ubuntu*>* 10.10 .*You need to give more information. The codegolf object How to professionally handle sexist remarks by a student? This effectively isolates the build by setting the PATH and other relevant variables and uses scripts to filter out or inject options to cc and other compilers and build tools. It would probably be helpful if you could attach the crash log.

running build running build_ext make: *** [sharedmods] Error 139 $ uname -a Linux k.b.com 2.4.20-20.8 #1 Mon Aug 18 14:59:07 EDT 2003 i686 i686 i386 GNU/Linux $ gcc -v Reading specs Didn't see that coming at all. If so, does "./python Lib/test/regrtest.py" reveal any problems besides lots of skipped tests because no extension modules have been built? https://bytes.com/topic/python/answers/23382-2-3-2-installation-problems Perhaps your doctor output may help us ...

running build running build_ext make: *** [sharedmods] Error 139 That looks like it exited in response to a SIGSEV. Worth checking into whether that's the issue here. Collaborator mistydemeo commented Mar 8, 2013 Can I see the value of uname -a? Basically every report I've seen for "Illegal instruction: 4" has been when software was compiled for a newer SDK than the OS the user was running on - but you're on

Can you provide a full brew doctor output? I insert a for loop like the following code in ceval.c and the compilation process freezes, or enters into an infinite loop. What exactly is python doing during the make process? #ifdef WITH_THREAD for(;;) { } if (interpreter_lock) { /* Give another thread a chance */ if (PyThreadState_Swap(NULL) != tstate) Py_FatalError("ceval: tstate mix-up"); Richard Tew 2010-12-17 12:32:17 UTC PermalinkRaw Message Post by 刘连响"gcc -pthread -Xlinker -export-dynamic -o python \Modules/python.o \libpython2.6.a -lpthread -ldl -lutil -lm/usr/local/src/python-2.65/./Modules/posixmodule.c:7207: warning: the use of`tmpnam_r' is dangerous, better use `mkstemp'/usr/local/src/python-2.65/./Modules/posixmodule.c:7162: warning:

Any ideas? http://divxpl.net/make/make-size-before-error-255.html You can solve this by adding the Homebrew remote: cd /usr/local git remote add origin https://github.com/mxcl/homebrew.git sh: line 1: 83414 Illegal instruction: 4 git status -s -- Library/Homebrew/ 2> /dev/null sh: Daniel BTW, is my first post on stackoverflow, hope I didn't make to much mistakes... I'll leave this ticket open for now so this has a chance of being answered.

adamv commented Mar 9, 2013 https://www.google.com/search?q=Illegal+instruction%3A+4 adamv commented Mar 9, 2013 (to deleted reply) I'm willing to close "resolved: hackintosh not supported" Collaborator mistydemeo commented Mar 10, 2013 Not sure where I think this weekend I might try and install a new version of OSX without the extra drivers or other modifications on a spare hard drive to see if it will Building on a fresh 10.8.2 installation with xcode 4.6's CLTs. Source To the --env=std thing: Homebrew nowadays defaults to something called 'superenv'.

it really does not have more informations thinks > On Fri, Dec 17, 2010 at 6:32 PM, 刘连响 > wrote: > >* the error is*>* Segmentation fault (core Can I see a --env=std verbose build log so I can see what flags homebrew is setting? Contact Gossamer Threads Web Applications & Managed Hosting Powered by Gossamer Threads Inc. 418,947 Members | 1,312 Online Join Now login Ask Question Home Questions Articles Browse

Is this a possibility?Cheers,Richard.yeah, i think it maybe the gcc' problem.

Browse other questions tagged python redhat or ask your own question. https://gist.github.com/anonymous/976db8530992754d6323 Collaborator mistydemeo commented Mar 9, 2013 From your manual build: gcc -c -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I. -IInclude -I./Include -DPy_BUILD_CORE -o Python/sysmodule.o Python/sysmodule.c And from wizpig64 commented Mar 8, 2013 As I put in the second gist: 'Your system is raring to brew.' both before and after attempting the install. URL: Previous message: [Stackless] when i compile the stackless-2.6.5 , i came to the Error 139 Next message: [Stackless] when i compile the stackless-2.6.5 , i came to the Error

Skip PyUser Jul 18 '05 #3 P: n/a Skip Montanaro Hi Skip, >> running build_ext >> make: *** [sharedmods] Error 139 Do you have any more output than that? python redhat share|improve this question asked Jun 29 at 11:58 D.Bue 12 add a comment| 1 Answer 1 active oldest votes up vote 0 down vote I suggest using the RH What is this aircraft with elaborate folding wings? http://divxpl.net/make/make-top-o-error-1.html Not that I don't want to support you, but I have seen mysterious issues caused by hackintoshes before.

it seems I had to remove even more from previous brew installs. Is this a possibility?Cheers,Richard.yeah, i think it maybe the gcc' problem. When I run 'make', I get the following error: .... .... Already have an account?

Thanks! $ brew install python ==> Downloading http://www.python.org/ftp/python/2.7.3/Python-2.7.3.tar.bz2 Already downloaded: /Library/Caches/Homebrew/python-2.7.3.tar.bz2 ==> Downloading patches ######################################################################## 100.0% ==> Patching patching file Lib/shutil.py patching file Lib/test/test_shutil.py patching file Modules/errnomodule.c ==> ./configure --prefix=/usr/local/Cellar/python/2.7.3 --enable-ipv6 I have doubts, seeing as how the VM didn't work, but it's worth a shot. Hey there. It doesn't get far; the first import of random fails, failing to import math.

mistydemeo closed this Mar 10, 2013 wizpig64 commented Mar 10, 2013 Thanks for your time guys. @adamv sorry to be an ass, was pretty tired at the moment of writing, not Shortest code to produce non-deterministic output Does using documentation as a developer make me look unprofessional? This suggests that the problem isn't that you're miscompiling software, which would have seemed more likely, but that you can't run software compiled with certain settings. From a cursory glance at Google, it looks like Illegal instruction: 4 could be a) an issue with the SDK version it's building against (which seems improbable, given that you're both

wizpig64 commented Mar 9, 2013 Yup, same exact error, from what I recall. The following gist is the log for me installing brew, attempting to install python, and then showing the log file. Well since neither of us can figure it out, it's confession time.